Pip 无法在Windows 64位上将ipython从1.1升级到4.0

我无法正确升级或安装ipython C:\big data\ipython-notebooks>pip install --upgrade ipython Downloading/unpacking ipython from https://pypi.python.org/packages/source/i/ipython/ipython-4.0.0b1.tar.gz#md 5=e32e4ea0ed8312311bb8cb3e0af0bea1 Running setup.py egg_

如何使用Pip卸载部分安装的模块

我最近决定尝试在我的计算机上安装tesseract,并运行了pip3安装tesseract ocr 然后它开始下载cython,提醒我tesseract ocr不是我想要的,所以我按CTRL-C取消命令 然而,似乎在我的目录中仍然有一个Cython文件夹;取消后,pip没有清理干净。另外,我不能使用pip卸载cython,因为它告诉我它还没有安装 我该怎么做才能彻底清除Cython?FWIW,您提供的包名似乎不在全局pypi索引中,因此您可能遗漏了一些步骤 pip3 install opencv

pip错误:找不到与google api python客户端匹配的发行版

我正在遵循这篇关于Firebase和Google App Engine的博客文章中概述的步骤 当我尝试运行时: pip install -t lib -r requirements.txt 我得到以下错误: Could not fetch URL https://pypi.python.org/simple/google-api-python-client/: There was a problem confirming the ssl certificate: [SSL: TLSV1_AL

Pip Linux上的Lektor安装失败

Lektor在Linux(Mint 19和Raspbian-armv7l 2018-10)上安装时崩溃,出现“找不到文件错误” 已安装Python 2.7和3.5。 sudo apt get install python dev libssl dev libffi dev OK sudo apt获取安装imagemagick OK curl-sfhttps://www.getlektor.com/install.sh |苏多什 此脚本将在您的计算机上安装Lektor。 安装地点: bin:/us

我是否可以使用pip仅使直接安装的软件包保持最新?

如何列出直接使用pip安装的软件包,从而忽略已安装的任何依赖项 我有一个运行过的virtualenv,命令如下 $ pip install A B C $ pip install X Y Z 因此,我不仅安装了a、B、C、X、Y和Z,而且还安装了p、q、r、s、t、u、v和w。但看看任何给定的包,我都记不起它是否是我直接安装的。我想保持这个venv中直接安装的软件包的最新版本,比如 $ pip install -U --directly-installed 这就产生了 $ pip insta

阻止Pip隐式安装包

是否有任何指令指示pip不要安装任何软件包,除非它们在命令行或requirements.txt文件中明确指定?: 不要安装软件包依赖项 pip install --no-deps

Pip 安装Google数据存储时下载/解包错误

我正在使用PIP1.5.4试用googleDataStore和教程 我在Mac上运行,在安装数据存储时遇到了麻烦 virtualenv gcd gcd/bin/pip install googledatastore 我犯了一个错误 Downloading/unpacking googledatastore Could not find a version that satisfies the requirement googledatastore (from versions: v1beta

pip卸载jupyter:不工作

我已经完成了pip安装——用户jupyter。 它在.local/中安装jupyter。 我用:pip uninstall jupyter卸载了它 它似乎卸载了,而whic jupyter什么也没有返回 但是,所有文件仍位于.local下。pip列表确实显示了ipython和ipython genutils。 当我运行.local/bin/ipython时,它会运行 你能告诉我如何卸载jupyter吗? 谢谢 T@Rao,你在回答一个不同的问题@Terry,pip仅卸载您指定的程序。它不会自动删

我应该使用pip或pip3在虚拟环境中安装python3软件包吗?

我的Linux机器上有python 2(默认设置)和python 3。我创建了一个虚拟环境,用python3试用pandas。所以,我跑: virtualenv-p python3熊猫_env 如果我在这个环境中键入python,它将进入标准的pythonshell,默认版本为python3 (panda_env)$ python Python 3.4.3 (default, Sep 14 2016, 12:36:27) [GCC 4.8.4] on linux Type "help", "c

我是否需要为每个新环境配置Conda和pip之间的互操作性?

从Conda 4.6开始,可以将Conda配置为使用pip()直接安装PyPi软件包。具体来说,您需要通过conda config--set pip\u interop\u enabled True手动启用它 我不知道如何检查Conda的现有配置,因此我无法判断此设置是否在整个环境中全局保持,或者是否需要在每次创建新环境时手动启用。有什么想法吗 到目前为止,我几乎看不到有人提到这个功能,我想这是可以理解的,因为官方文章才发表了大约3个月。到目前为止,我只在一个涉及此功能的问题中找到了一个答案,这

Pip 如何将现有的python包部署到jFrog Artifactory?

我希望python包“numpy”出现在我们的组织工件中。我从pypi(pip install numpy)下载了这个包,现在我想将它上传到Artifactory 正确的方法是什么?这可以通过使用distutils、setuptools或Python来实现 您可以通过一些示例找到相关文档。您是否使用Artifactory代理pypi(通过远程存储库)?这是一种将python工件放入组织的更简单的方法否,我使用artifactory作为包的单一源,我想将包直接上传到artifactory

Pip Python中的树莓Pi-GPIO

我试图让我的树莓皮的GPIO引脚工作,我下面 (我正在通过SSH运行Raspbian。)我已成功安装distribute 在尝试安装PIP时,出现如下错误 我怎样才能修好它 pi@DuckPi ~ $ sudo curl https://raw.github.com/pypa/pip/master/contrib/get-pip.py | python % Total % Received % Xferd Average Speed Time Time

我的Pip指向错误的路径,无法在virtualenv中安装软件包

我想在Ubuntu14.04上用python3.4和pip3创建一个virtualenv,但我做不到。我已经试过在我正常的ubuntu14.04LTS机器上和livecd的一台新机器上从头开始检查它,但我无法让它工作。我尝试过virtualenv(有VirtualEnvRapper和没有VirtualEnvRapper)和很多不同的命令、工具和脚本,但都没有成功。这浪费了两天时间,搞砸了Python2.7,特别是pip的不同版本。让我尽可能详细地解释,以帮助您理解: 正如你所知,Ubuntu 1

使用pip安装iPython笔记本电脑

编辑: 根据pip网站(),我应该已经在pythonversion2.9.7中安装了pip,但是我假设我没有安装,因为有错误消息 然后我试图通过下载get-pip.py来安装pip。这是成功的,但我得到了信息: Found existing installation: pip 1.3.1 Uninstalling pip-1.3.1: Successfully uninstalled pip-1.3.1 Successfully installed pip-8.1.1 wheel-0.29.0

Pip 安装仪表板时出现问题(绘图)

当尝试使用pip和conda安装Dash包时,我收到一个错误,说明找不到该包。所有其他软件包都可以使用pip安装 仪表板组件: 例外情况: 回溯(最近一次呼叫最后一次): 文件“C:\Users\Owner\Anaconda3\lib\site packages\pip\basecommand.py”,第215行,在main中 status=self.run(选项、参数) 文件“C:\Users\Owner\Anaconda3\lib\site packages\pip\commands\in

I';我试图用Python3.9.0安装Kivy,在我键入Python-mpipinstallKivy之后,它给了我一个错误

我在Windows10上。 我按照上的说明进行操作,到达了上面写着: 安装Kivy: python -m pip install kivy==1.11.1 在cmd中键入后,它会给我一个错误。我将把这个错误作为注释 尝试pip安装pipwin,然后pipwin安装kivy==1.11.1 归功于pip,请尝试安装,键入终端: pip安装kivy[base]kivy\u示例--预-额外索引urlhttps://kivy.org/downloads/simple/不要把这个错误当作答案。它以格式化

为什么IronPython告诉我pip是一个包而不是一个可执行文件?

我是Python的新手。我想看看Pyomo(一个用于数学建模的Python包)是否可以在IronPython下工作,因为我生成Pyomo所需数据的所有代码都是用C#编写的 我安装了IronPython2.7.5,然后作为管理员尝试了关于如何为IronPython运行“pip”的建议。我使用了他们给出的确切示例(安装html5lib): 第一行工作正常,我在Lib/site packages目录中看到一个名为pip-6.1.1-py2.7.egg的文件夹,其中包含大量python代码 对于第二行,

Pip PyPi包vmprof无法在64位Windows 7计算机上安装

如果能帮我诊断,我将不胜感激 错误消息可能表明此程序包无法安装在64位计算机上,或者选择了错误的编译器 编辑: forvmprof声明它将仅在x86(32位)上运行。很明显,应该指示C编译器将源代码编译为32位。这是否表明vmprof包装中存在不足,应作为vmprof问题提出结束编辑。 不管怎样,我都不知道如何解决那个问题。我正在从命令行运行pip install vmprof 警告C4311: 警告C4312: 这两个警告让我怀疑PyPi是否无法将vmprof安装到我的64位环境中。但是,如果

在windows10中安装pip时出错

我已尝试使用以下命令安装pip: sudo-apt-install-python-pip 但在安装了一些文件并要求管理员权限后,它会在一个文件上卡住,从而导致错误- “错误:1 xenial更新/main amd64 linux libc dev amd64 4.4.0-77.98 404未找到[IP:91.189.88.149 80] E:未能获取404未找到[IP:91.189.88.149 80] " 我正在Windows10(bash)上使用python 3.5.2 附言:是的,我完全不

PIP3命令显示';模块';对象不可调用

每当运行pip3命令时,都会出现以下错误: $ pip3 --version Traceback (most recent call last): File "/usr/bin/pip3", line 9, in <module> load_entry_point('pip==1.5', 'console_scripts', 'pip3')() File "/usr/lib/python3.4/site-packages/pip/__init__.py", line

Pip 从另一个分支上的github子目录安装python包

我在url中有一个python包,类似这样 https://github.com/my_profile/repo/tree/not_master_branch/folder_1/package 我知道要通过pip安装软件包,它是: pip install git+https://github.com/user/repo.git@branch 但是如何指定文件夹呢 python -m pip install 'git+https://github.com/user/repo.git@branc

Pip 安装模块后,在虚拟环境中找不到该模块

我使用“git submodule add mymodule”将一个git子模块添加到我的项目中。项目包含在虚拟环境中。在切换到子模块目录后,我使用“pip install”安装了子模块。如果我运行pipfreeze,mymodule似乎已成功安装。但是,当我在代码中导入mymodule并运行代码时,会出现ModuleNotFoundError 我真的不确定下一步该试什么。我可以进入虚拟环境的site packages文件夹,我可以看到mymodule的所有文件(包括dunder init.py

Pip Windows环境下的串行通信复制

我遇到了以下代码,我认为这些代码可以将数据从COM3复制到COM1(在另一个进程使用COM时无法访问COM) 导入序列号 波特率=9600#您正在收听的任何波特率 com_端口1='COM3'#替换为第一个com端口路径 com_端口2='COM1'#替换为第二个com端口路径 listener=serial.serial(com端口1,波特率) 转发器=serial.serial(com端口2,波特率) 而1: 串行输出=侦听器.读取(大小=1) #打印(串行输出)或将其写入文件 转发器。写

PIP在Windows 8上在何处存储/保存Python 3模块/包?

我到处都找过了,找不到软件包的安装位置 此外,这些包是来自、模块、库还是术语包?来自 Python通常将其库(以及站点包文件夹)存储在安装目录中。因此,如果已将Python安装到C:\Python\,则默认库将驻留在C:\Python\Lib\中,第三方模块应存储在C:\Python\Lib\站点包中 对于python 3.X的默认位置C:\Users\username\AppData\Local\Programs\Python36\Lib\site软件包,使用此命令列出全局软件包及其位置: p

pip未更新到最新版本

当我运行pip安装-U pip时,它不会安装较新的版本 drahcir@Altair:~/dev$ pip --version pip 1.5.6 from /usr/lib/python2.7/dist-packages (python 2.7) drahcir@Altair:~/dev$ pip install -U pip Downloading/unpacking pip Downloading pip-8.1.2-py2.py3-none-any.whl (1.2MB): 1.2M

带Anaconda的Pip:如何使Pip安装到激活的环境站点包文件夹?

我正在尝试测试一个我已经构建的软件包,并希望看到在安装我的软件包时,使用新计算机的用户可能会体验到什么。我决定通过以下方式创建一个新的python环境来模拟这一点: conda create --name testpython35 python=3.5 然后,当我激活该环境并执行以下操作时: import pandas 我没有收到错误,我希望出现一个ImportError 我如何使用conda和pip安装一个完全干净的python环境,以便我可以测试我的软件包?您创建了一个新环境,但没有在其

pip和conda的最佳实践,以实现一致性

我知道关于pip和conda的共存性和互换性/不互换性有很多问题。这不是我的问题:我知道我的工作需要两者,我使用两者,而且在大多数情况下,我的conda envs是一个可管理的混乱 但问题是:有很多方法可以安装pip。我碰巧先得到了conda,所以我的pip是通过anaconda/bin/pip。这是我机器上唯一的pip。以下是我的问题: 这是否合理?我是否希望我的pip成为usr/bin/pip并独立于全局conda?这感觉不明智 如果我通过saybrew或easy\u install安装一个

virtualenv上的pip安装-r requirement.txt不';即使在激活后,也不能在本地但在全局安装

我试图在我的requirements.txt(一组软件包列表)中安装所有依赖项。 我所做的: 已创建虚拟环境virtualenv my_env 激活新的虚拟环境后,我可以在提示符(my_env)$ ranpip安装-r requirements.txt 所有软件包都已安装,但当使用pip freeze检查时,我什么都没有。尝试停用虚拟环境,并再次使pip冻结,我已全部安装完毕 我有点困惑,因为我非常确定我的虚拟环境被激活了,而且我在做哪个pip时有正确的pip路径(/home/virtual

Pip 所有软件包都安装在全新的python venv中

因此,假设我有一个文件夹main,然后运行 python -m venv vir_env/ source vir_env/Scritps/activate (vir_env) pip list 它列出了我安装的所有软件包,而不仅仅是pip和setuptools 有没有办法得到一个“干净”的venv 我正在运行windows 10,使用GitBash作为终端什么python版本?默认情况下,不应继承系统包。尝试运行which pip,以确保您在虚拟环境中实际运行了pip,可能路径没有正确调整?

Pip 为pynacl构建轮子失败意味着什么?

有时,在安装与python项目相关的需求时,我会得到“用于加密的构建轮子失败”或“用于pynacl的构建轮子失败” 然后我得到“Running setup.py bdist_wheel for cryptography” 这里发生了什么?有什么值得关注的吗?或者只是通过另一种方法安装软件包

Pip 开发使用第三方python库的自定义ansible模块时设置环境的正确方法

我开发了一个自定义ansible模块,它依赖于第三方库PyYAML。然而,运行剧本会带来收益 ansible_module_my_module.py, line 5, in <module> import yaml ImportError: No module named yaml 但这意味着playbook知道深入堆栈的模块的实现细节,这似乎是错误的。我的期望是,有某种方法可以告诉ansible在远程机器上安装第三方库,作为其设置的一部分。例如,在我的模块中添加require

Pip 安装用于OpenAI Gym的Box2D Python包时出错

我正在尝试在Windows10中安装OpenAI的Gym 我顺利地完成了大部分步骤。但是,在使用pip安装Box2D的步骤中,我得到以下错误MyEnv是我当前的conda环境。我如何解决这个问题 (MyEnv) C:\Users\me>pip install Box2D Collecting Box2D Using cached https://files.pythonhosted.org/packages/cc/7b/ddb96fea1fa5b24f8929714ef483f64c3

Pip `ansible--version`命令引发错误

大家好 我已经在我的mac上安装了ansible,它已成功安装,但当我运行命令ansible--version时,它抛出一个错误: Unhandled error: Traceback (most recent call last): File "/Library/Python/2.7/site-packages/ansible/config/manager.py", line 559, in update_config_data value, origin = self.get_

Pip 无法运行同名的mkdocs-主题

我安装了一个主题,执行此操作后,从命令行运行和mkdocs命令时,出现以下错误: Traceback (most recent call last): File "/usr/local/bin/mkdocs", line 5, in <module> from mkdocs.__main__ import cli File "/usr/local/lib/python2.7/site-packages/mkdocs/__main__.py", line 78, in

Pip 更新conda后conda环境已损坏

在广泛使用conda一段时间后,昨天有人要求我更新它,现在一切看起来都坏了。我必须承认,我不是幕后活动的专家,所以请容忍我:) 安装conda后,我使用pip安装了各种软件包。 昨天,我开始编写git教程中的一些代码,该教程建议创建一个临时环境来使用: conda env create -f binder/environment.yml 在这一步,有人建议我更新conda,因为我使用的是旧版本。我在终端中找不到该特定消息(即,我找不到我以前使用的conda版本),但我现在检查conda版本时得

我可以列出所有可用的带有pip的索引服务器吗?

我在~/.pypirc文件中添加了一个索引服务器,如下所示: [distutils] index-servers = example [example] repository: https://example.com/simple/ username: someplaintextusername password: someplaintextpw 但是,我无法安装一个肯定在示例索引服务器上的包。现在我想检查pip是否在pypirc文件中注意到了该服务器 我可以让pip列出所有可用的索引服务器

在YAML文件中指定conda和pip包版本号时,=和==等意味着什么

我们使用YAML文件来指定我们的conda和pip环境。在它们中,我们可以指定需要使用的版本号,例如,这些行中的任何一行 -cudatoolkit=10.2.89 -cudatoolkit=10.2* -cudatoolkit==10.2.89 -cudatoolkit==10.2* 我很难找到这些包要求中==与=的区别,以及可以编写哪些其他限制以及如何编写的文档 此设置在=和=之间有什么区别?conda和pip之间的这些含义有区别吗?正确的文档在哪里(Google和Bing不擅长搜索类似的符

Pip 修补程序和需求文件的幂等Bash脚本

我有一个python项目,它有自己的需求文件。该项目也有自己的virtualenv,其中一个包是“pyPdf”。这个库有一个bug,我写了一个补丁来修复这个bug --- venv/local/lib/python2.7/site-packages/pyPdf/pdf.py 2014-07-17 17:04:57.000000000 +0530 +++ pypdf_fixer.py 2014-07-19 01:19:53.176877332 +0530 @@ -1726,7 +1726,10

将Ansible命令转换为pip任务

我想将以下内容转换为Ansible pip任务: - name: install packages and setup profile 3 shell: pip install --user vex 我在Ansible文档中没有看到任何关于为用户安装的信息。您可以使用withextra_args参数: - name: install packages and setup profile 3 pip: name: vex state: present extra_

Pip “命令”;python setup.py egg“u info”;失败,错误代码为1-无法修复

我和皮普有麻烦 我已经安装并更新了Setuptools、pip、ez_setup和django。我还尝试从tar.gz手动安装包,但没有成功 仍然收到相同的错误: 编辑:我不知道如何在代码中发布 使用缓存的postmaster-0.9.3.tar.gz收集邮局主管 从命令python setup.py egg_info完成输出: 回溯(最近一次呼叫最后一次): 文件“” 第1行,在 文件“C:\Users\m\u cur\AppData\Local\Temp\pip-build-kkkd0jbr

Pip Pycharm卡在“上”;“安装组件”;,如何获取日志信息?

我正在Windows101803上运行PyCharm Professional 2019.1.3。Python3.7.3和PIP19.1.1 突然之间,我无法在Pycharm中使用PipEnv安装软件包。无论软件包是什么,它都会卡在“安装软件包…”上。我在不同的文件夹中尝试了新项目,禁用了CrashPlan(我无法禁用防病毒软件(TrendMicro)) 从CLI安装软件包时没有问题 我查看了C:\Users\\.PyCharm2019.1\system\log文件夹,idea.log文件没有提

Pip 安装spyder终端时出现退出状态1错误

错误:命令出错,退出状态为1:'c:\users\admin\appdata\local\programs\python\python38-32\python.exe'-u-c'import sys,setuptools,tokenize;sys.argv[0]=“C:\Users\Admin\AppData\Local\Temp\pip-install-z3vdlz4p\pywinpty\setup.py”“”文件=''''''''''''''''C:\Users\Admin\AppData\

Pip Python3找不到statsmodels.api,但我可以,我的linter也可以

我最近开始开发运行在WSL(Ubuntu18.04LTS)上的Python 我遵循了中的文档,能够运行简单的python脚本 我开始尝试使用pip3命令安装的库,例如numpy和pandas,这些库工作得很好 当我尝试使用statsmodels包时,问题就出现了。 我使用pip3安装statsmodels安装了它 我可以在/home/username/.local/lib/python3.6/site packages/statsmodels中看到包,但我甚至可以在该目录中看到api.py文件,

Pip Python3我尝试在windows10上安装lshash 0.0.4dev

我正在尝试安装lshash 0.0.4dev 使用pip在anconda promot上安装lshash 我得到了这个错误: (基本)C:\Users\User>python-mpip安装lshash 收集lshash 使用缓存的lshash-0.0.4dev.tar.gz(7.2kb) 错误:命令出错,退出状态为1: 命令:“C:\ProgramData\Anaconda3\python.exe'-C”import sys,setuptools,tokenize;sys.argv[0]=“C

Pip 安装后导入syft会导致火炬错误

我已经使用下面的命令在Windows10上创建的虚拟环境中安装了syft python -m venv demo 在此之后,我激活了虚拟环境,打开了jupyter笔记本,并尝试通过它安装最新版本的syft !pip install syft 安装成功,没有任何错误。 但是,当我尝试导入相同的内容时,会出现“torch”错误 import syft as sy ModuleNotFoundError Traceback (most recent c

为什么AWS CLI pip软件包安装会安装一个它可以安装的六个软件包';我没用?

每当我使用更新AWS CLI时 pip install -U awscli 它将多个软件包降级(colorama、dill、rsa、和websocket客户端),并将six升级为无法使用的版本(1.9.0)。更新后,如果我尝试使用AWS CLI(例如,eb status),我会 回溯(最近一次呼叫最后一次): 文件“/usr/local/bin/eb”,第5行,在 从打包资源导入加载入口点 文件“/Library/Python/2.7/site packages/pkg_resources/_

我使用pip卸载卸载了一个软件包,但无法重新安装

这是我在使用pip uninstall matplotlib后键入的内容: pip install matplotlib 但这就是结果: Could not find a version that satisfies the requirement matplotlib (from versions: ) No matching distribution found for matplotlib 我在Mac上运行这个,我是Python新手。任何帮助都将不胜感激 这可能是因为您的TLS版本。从

自动安装pip软件包';操作系统依赖项

我正在一个debootstrap'd Debian上安装大量的pip包,可以理解,Debian非常简陋,缺少常规安装通常需要的大量包。当然,pip安装会失败,因为操作系统没有它们所依赖的库 有没有一种方法可以让pip解析apt依赖项,而不是单独挖掘我需要安装的依赖项?没有。pip是一种便携式工具,专为在许多操作系统上运行而设计。但是在每一个操作系统上,pip都只使用Python包,不涉及系统库。如果使用apt或任何其他特定于发行版的包管理器安装Python包,它将处理所有依赖项。当您将pip添加

Pip 没有名为pymc3的模块

您好,我正在尝试在pip从Python.exe所在的库中的命令行安装pymc3之后导入它。(即>>python-mpip安装pymc3)。在检查Lib/Site软件包库之后,没有pymc3,但是安装了theanos软件包。我到处找pymc3软件包,但都找不到。我试着安装pymc4,同样的事情也发生了。知道为什么吗?您应该能够直接在命令行中运行pip。 IE:命令是“pip install pymc3” 然后您需要导入它。 您的问题还可能是您最近安装了python并安装了pip3,而不是pip。您

  1    2   3   4   5   6  ... 下一页 最后一页 共 7 页