如何以编程方式运行Eclipse启动配置?

我发现很难很好地表达这个问题,因为有很多通用术语(运行、配置、启动等)。下面是: 你可以。(在“运行配置”对话框的“公用”选项卡下,另存为共享文件 我们将这些文件签入SVN。开发人员可以传递这些文件,这有助于让新开发人员更快地运行工作应用程序 我想在构建过程中检查这些,并使用它们以编程方式运行应用程序、测试等,而不必旋转整个IDE 在UI之外运行.launch文件的最佳方式是什么 编辑:我正在尝试统一在构建服务器和IDE上运行的测试。我没有 特别是想要放弃集成调试,这将是使用ant脚本来运行测试

从Eclipse中以编程方式安装Eclipse插件?

我想为Eclipse插件创建一个自动安装程序(即,不通过“更新管理器”)。我的场景很简单:用户关闭Eclipse,将下载的JAR放入dropins文件夹,启动Eclipse,剩下的过程是自动化的 在P2时代之前的较旧版本中,Eclipse有(现在仍然有)一个名为InstallCommand的类,可用于将plugins安装到当前运行的平台中 尽管这在Eclipse3.4和3.5中仍然有效,但它的行为并不正常:最明显的是,以这种方式安装的插件无法自动卸载(它变暗) JavaDoc声称InstallC

Eclipse-缺少Mac Os默认JRE

已安装JRE的列表是空的,当我单击“添加”时,我得到的唯一选项是- 执行环境描述, 标准1.1.x虚拟机, 标准虚拟机 MacOS默认JRE没有选项,选择标准VM会导致通常的“MacOS上不支持标准VM” 伽利略月食, MacOSX10.5.8 非常感谢您的任何建议您有一个“添加”按钮,可用于添加新的JVM。事实上,甚至应该有一个“查找JVM”按钮 如果您手头没有JDK,只需从Sun下载JDK,然后使用add将其添加到JVM列表中,并将其设置为默认值。我不确定您的问题到底是什么 如果您想知道JV

如何定制Eclipse';s文本编辑器代码格式

如何将Eclipse的代码格式化程序设置为允许代码行长度超过80个字符。我知道很长的行很难阅读,但在我看来,对于宽屏幕显示器来说,每行80个字符是非常小的值。在“首选项”中,转到“Java>代码样式>格式化程序”,编辑/创建格式化程序,然后转到“制表符换行”。您可以在中设置最大线宽 此外,您还可以在常规>编辑器>文本编辑器中设置打印边距列,该列应向上移动边距(代码右侧的1px宽垂直线)到所需位置。但是,这不会影响格式化程序,只会影响人眼。这个答案有点旧,并且随着新版本的Eclipse的出现,路径

Eclipse类路径和NoClassDefFoundError

我将尽可能多地提供细节,如果有一些是不相关的,请原谅。 我在eclipse中有两个项目。项目1:com.myworkplace.parent,包中的代码同名。项目2:com.myworkplace.child,包中的代码具有相同的名称(我将代码从默认包移动到该包中,如果这样做会产生差异的话)。据我所知,它们都位于我的工作区文件夹中,并按照您所期望的方式进行结构 我已经使用Java build path->Projects->Add将子元素添加到eclipse中父元素的构建路径中。父级的.clas

Eclipse 如何将点目录添加到Mercurial hgignore

我已经使用mercurial一段时间了,在使用hgignore时从未遇到任何问题。 现在我已经使用eclipse创建了一个新项目,它添加了一个.metadata目录。 我似乎无法忽略.metadata nils@yavin $ hg status ? .metadata/.mylyn/repositories.xml.zip ? .metadata/.plugins/org.eclipse.core.resources/.history/37/509db4063df7001f14dbbfe704

面向JavaScript Web开发人员的Eclipse IDE+;亚唇+;MacOSX10.6上的JavaHL

我想在雪豹上使用Eclipse插件Subclipse。 我为JavaScript Web开发人员安装了EclipseIDE(HeliosServiceRelease1) 我应该提到,subversion服务器受SSL保护,我必须使用个人证书(p12文件) 我告诉系统在哪里可以找到证书文件 /Users/<USERNAME>/.subversion/servers 我认为使用较新的SVN版本+JavaHL(Snow Leopard的预安装SVN为1.0)可能是个好主意,但根据需要,至

如何从浏览器打开eclipse中的帮助窗口

假设我有一个携带静态html文件的浏览器 现在我在提供的页面中有一个超链接 html和onn单击我想要的链接 打开的“帮助”独立窗口的步骤 日蚀 方法是什么。在Eclipse欢迎页面中,此场景已经存在,但无法证明我的要求是正确的。为什么要从浏览器打开Eclipse的独立帮助?为什么不在浏览器中打开它呢?URL类似于: 您还可以从命令行启动Eclipse的独立帮助: cd $ECLIPSE_HOME java -cp plugins\org.eclipse.help.base_3.4.0.v201

Maven和Eclipse代码组织

我是Maven的新手,在阅读了Maven网站上的文档和Sonatype的在线Maven书籍之后,我仍然不清楚如何最好地组织事情 我有两个应用程序,A和B共享mylib的代码。不同的开发者在应用程序A和应用程序B上工作,它们是独立发布的。在我们开始使用maven之前,在Eclipse中,我有一个包含应用程序a、B和mylib的工作区。应用程序A的类路径包含mylib。如果我在mylib中做了更改,按runwitheclipse,就会包含我的最新更改 在Maven中,我可以创建一个父pom.xml,

在Eclipse中是否有开发iPad应用程序的方法?

只是不喜欢Xcode,有可能吗 有人试过吗 提前感谢。上次我检查时,iPad不运行Java应用程序。如果您正在开发HTML/CSS/Javascript应用程序,那么可以。你可以用Aptana。如果没有,最好使用Xcode,我想您应该开发本地iPad应用程序。如果是,则无法使用Objective-C和Eclipse开发iPad应用程序 最后我检查了一下,Eclipse并不总是指Javatouche。但是,这个问题是在我回答之后编辑的,所以我可能是根据原来的问题来回答的。

eclipse工作区:如何重命名工作区

“文件”菜单中没有重命名工作区的选项。是否建议关闭eclipse、重命名文件夹并重新打开?我担心配置文件中的一些潜在悬挂引用会损坏我的工作区/项目 谢谢 将工作区复制到新文件夹有效。Eclipse本身需要的任何引用都使用相对工作区位置来解决。如果您添加了依赖于绝对工作区位置的启动器、替换变量等,则需要重置它们。来源: 是的,您可以重命名工作区 目录和/或移动它。然而,你 然后必须告诉Eclipse 新的工作区是。在3.1中,您可以使用 要在中启动的“切换工作区” 不同位置(文件下) 菜单) 如果

EclipseRCP-更新

在创建示例时,我注意到非常奇怪的行为,因此我有点被卡住了。我将在两个场景中解释这个问题 情景1。 创建两个插件 创建两个功能 创建一个产品&仅包含一个功能 创建一个类别并包含这两个要素 导出产品并使用生成的启动器进行测试。一切正常 现在导出可部署功能并将生成的文件复制到webserver中。 打开“安装新软件”选项,并使用URL安装第二项功能。 该功能在每次构建时都会得到安装甚至更新 情景2 创建两个插件 创建两个功能 创建一个产品&包括两个功能。(这与第一种方案不同,第一种方案只包含一个

Eclipse WtkobFousate参数问题

我有一个带有以下代码的ant构建: <wtkobfuscate jarfile="${dist}/${product.name}.jar" jadfile="${dist}/${product.name}.jad" verbose="true"> <classpath> <path location="${wtk.home}/lib/j2me-xmlrpc.jar" /> <!-- path l

Eclipse 我提交了一个svn文件删除,现在我想要它回来

我从env中删除了一堆文件并提交了更改。 当然我现在想要一个回来 将一个文件从修订版中恢复的最佳方式是什么 我已经从包上的查看历史记录(它是一个java文件)中找到了这个文件,但是在缺少复制和粘贴的情况下,我看不到将其恢复的方法 Eclipse 3.7.0,subclipse 1.6 更新 安东尼奥·佩雷斯(Antonio pérez)和qor72解决方案似乎都实现了这一目标。Antonio的可以在eclipse中完成,但恢复的数量可能很大。还合并提交打开的更改的请求 我喜欢qor72的解决方案

eclipse的SpringIDE版本赢得了';我不允许安装Eclipse Market Place

我最近下载了SpringIDE完整下载,而不是下载eclipse和插件 因此,现在我去更新网站,那里什么都没有。。。因此,我添加以下内容 这里提到了这一点 并尝试安装市场,但我得到以下错误 无法完成安装,因为可能会出现一个或多个必需项 找不到。正在安装的软件:Marketplace客户端 1.1.1.I20110907-0947(org.eclipse.epp.mpc.feature.group 1.1.1.I20110907-0947)缺少要求:Marketplace Client 1.1.

Eclipse 从基本分支更新git

很抱歉,这可能是重复的,但我真的很难找到正确的答案 最初我做了一个叉子 这创造了 如何“更新”我的分支,使其与基本修订版相同,类似于SVN中的合并?抱歉,这可能非常简单,但我对GIT非常陌生,是否可以在Eclipse中使用egit实现这一点 谢谢,如果您想要一个特定的版本,那么您只需要执行以下操作: git checkout <revision> git签出 如果你熟悉svn,我觉得这很有帮助 更新: 如果需要最新版本,请执行以下操作: git pull <origin&g

EclipseJCOP-重建项目?

我在eclipse中使用jcop工具插件,我的atr是:- --Opening terminal <div class="jive-quote"> /card -a a000000003000000 -c com.ibm.jc.CardManager</div> --Waiting for card... ATR=3B E9 00 00 81 31 FE 45 4A 43 4F 50 34 31 56 32 ;....1.EJCOP41V2 32 A7

在eclipse上升级了eclipse和testng,现在我的项目没有运行

我的项目状态良好,可以右键单击testng.xml文件并作为testng套件运行,没有任何错误 现在,在通过eclipse>Help>CheckforUpdates升级eclipse和testng之后,当我尝试运行同一个项目时,我会遇到一大堆错误 以下是我遇到的错误的顶部部分: org.apache.xmlbeans.impl.values.XmlValueDisconnectedException 在org.apache.xmlbeans.impl.values.XmlObjectBase.c

Tomcat未通过Eclipse启动(超时)

我正在尝试通过Eclipse运行Tomcat。这是我在过去几年中所做的事情。昨天还在工作,现在不行了。我得到的错误是 Server Tomcat v7.0 Server at localhost was unable to start within 45 seconds. If the server requires more time, try increasing the timeout in the server editor. 输出是 Jul 06, 2012 8:32:26 PM o

在Eclipse中制作的Qt应用程序不';开始

我已经试了几个小时来让eclipse、mingw和Qt工作,但我无法做到 无论我尝试什么,当我尝试运行qt应用程序(使用run或Debug,同样的方法)时,都不会出现任何窗口,几秒钟后,Eclipse会说“程序终止”。另一次我尝试(使用一些不同的配置),windows会给出“程序已停止”错误 如果我试图从eclipse外部启动应用程序,我会得到一个丢失的.dll错误 我已经安装了Qt4.8.1,eclipse的最新版本,我刚刚安装了MinGW的最新版本。我也在使用Eclipse的Qt插件。我正在

在我使用eclipse中的svn后,subclipse在sts中出现了中断

在很长一段时间里,我的subversion客户端工作得很好,我在sts中使用了一段时间,但有一天sts崩溃了,我回滚到eclipse中一段时间,在此期间,我使用subclipse更新了我的一个项目。现在STS已启动并再次运行,但由于某些原因,如果我尝试从STS更新或提交,则会出现以下错误: The path '{pathname}' appears to be part of a Subversion 1.7 or greater working copy. Please upgrade yo

当使用模式浏览器并双击返回的结果(Force.com)时,Eclipse挂起在Mac上

我正在学习Force.com,并正在试用模式浏览器。我可以得到查询的结果;但当我双击一个给定的结果时,Eclipse挂起 我的Mac(8GB)正在运行MacOSX(10.7.4)。Force.com IDE是25版,Eclipse是面向Web开发人员的Java EE IDE;朱诺释放 非常感谢您的建议。我认为问题在于我运行的Eclipse版本不受支持(Juno 4.2)。在“卸载”Eclipse并将Force.com IDE作为独立应用程序安装之后,我的环境工作得更好 我认为问题在于我运行的Ec

Eclipse文本编辑器中的多个装饰列

有没有一种方法可以在Eclipse编辑器中为decorators添加多个列。 例如,同一行上的断点和搜索箭头不能很好地相互配合 假设您是eclipse插件开发人员,您可以使用 但是,您不能以eclipse用户的身份更改它。我是以用户的身份查找它的。但也许我可以将该功能添加到调试插件:)

eclipse中的搜索引擎

我正在开发一个插件来删除eclipse工作区中的sysout语句。作为这个插件的一部分,我还想提供在eclipse搜索视图中搜索和查看sysout语句实例的功能。有没有一种方法可以使用EclipseJDTAPI做到这一点?您可以使用抽象语法树(AST)和Java模型来修改代码 为了保持抽象,您可以让用户在outline视图中标记要搜索(和替换)的表达式(在本例中为System.out)。然后,您可以通过ISelection访问选定的IMember,并使用SearchEngine查找对它的所有引用

在Eclipse中安装Egit时遇到问题

这里是Super noob,但我正在尝试在Eclipse Kepler for OS X中安装EGit。使用Eclipse market place,单击它并按install后,它会显示“无需更新。”EGit已在Eclipse Kepler的默认安装中提供-请参阅

Eclipse 使用新插件模板向导编辑Manifest.MF文件

我想创建一个包含声明性服务的插件模板。到目前为止,我一直在遵循“”的指导原则,该方法效果良好。 然后,我在MyOptionTemplateSection的updateModel(..)方法中生成OSGI-INF/my-component.xml文件,该方法也可以很好地工作 …但是我需要在我要创建的项目的MANIFEST.MF文件中添加一行,这就是我遇到的问题: 服务组件:OSGI-INF/mycomponent.xml 我如何才能最好地实现这一点? 在生成捆绑包之前,我看不到在项目模型中插入此文

弹簧罐';在Eclipse中调试时,无法从共享Gradle库(AutowiredBean中的依赖项)中找到类 问题定义

我有一个基于Gradle的SpringMVC项目。我有一个网站项目(ZearioWeb)、网络爬虫(ZearioWebCrawler)和共享类(ZearioSharedClientServerClasses)。web和web爬虫共享一些类(如DTO或VOs) 在我的web应用程序中,我有一个带有getWorkUnit方法的CrawlerController;这将调用CrawlerService实例(@Autowireddepdency)上的方法,该实例反过来使用共享库中的一些类 我的问题是,我可

如何卸载Eclipse子软件以解决冲突依赖关系?

我正在尝试使用(通过)安装Git for Eclipse 安装失败,出现错误: Cannot complete the install because of a conflicting dependency. Software being installed: Eclipse Git Team Provider 3.2.0.201312181205-r (org.eclipse.egit.feature.group 3.2.0.201312181205-r) Software curre

使eclipse检测gwt客户端代码中的编译错误

是否可以配置Eclipse,以便它能够检测到GWT不可用的类和方法的使用,并在早期编译失败,或者可能对自动完成隐藏它们?否,google Eclipse插件中还没有选项 理论上,在任何一次保存操作之后,以草稿模式调用gwt编译器都是可行的,但这可能非常缓慢 由于超级devmode的上一个gwt版本中有了新特性,这可能会快得多,因为编译器能够执行增量编译。但我认为这还不够快 无论如何,您可以在保存文件时尝试添加任务以编译项目: 右键单击项目->属性->构建器->新建(调用脚本或ant/maven任

Eclipse Portlet超类必须是有效的Portlet类

我将liferay-portal-6.1.1-ce-ga2与maven 2.2.1一起使用。。我想创建一个新的portlet!! 当我单击新建>liferay portlet时。。。使用eclipse。创建portlet之后,我在portlet.xml和pom.xml中发现了2个错误 portlet.xml: 。。。 javax.portlet.faces.GenericFacesPortlet 错误:在Java构建路径上找不到类javax.portlet.faces.GenericFaces

drools eclipse插件:无法显示或运算符的RETE视图

我正在尝试为drools业务规则系统构建一个基准,因为我必须考虑RETE算法的特殊性。Drools eclispe插件中的RETE视图提供了根据drl显示相应RETE网络的机会。查看下面的代码,使用此代码,RETE视图可以工作,但是如果我用| |-运算符替换&-运算符,RETE视图将显示NullPointException。有人能解释一下这种行为吗?正如我所看到的,这些语句对于| |-运算符仍然有效 编辑: 我试图精确地回答我的问题。 无论使用| |还是&&,RETE网络看起来都一样吗 pack

如何在eclipse上使用jena查询owl文件

我是Jena新手,我想使用Jena sparql实现来查询owl文件,我的代码如下所示: import com.hp.hpl.jena.ontology.OntModelSpec;; import com.hp.hpl.jena.query.Query; import com.hp.hpl.jena.query.QueryExecution; import com.hp.hpl.jena.query.QueryExecutionFactory; import com.hp.hpl.jena.qu

Eclipse IvyDe传递依赖限制

因为我们有大量的依赖项,所以我们更希望开发人员只使用项目的直接依赖项 我正在寻找一种自动执行的方法。我想到了Eclipse访问规则,但据我所知,它们需要手动添加 我知道我可以让ivyDE不解决传递依赖关系,但这会导致第三方JAR出现问题,而第三方JAR实际上需要传递依赖关系 是否有人有一个工作系统来强制执行这一点,或者可能有某种方式使用ant-/shell脚本在ivyDe容器上生成访问限制

为什么我的eclipse.ini文件不能识别以下命令?

我需要使用64位JRE来运行eclipse,我的浏览器需要使用32位JRE。为了区别,我希望将32位版本保留在系统路径上,并简单地告诉eclipse使用64位版本打开。根据对其他类似问题的回答,我了解到我应该能够通过在eclipse.ini文件中添加以下内容来做到这一点: -vm C:\users\myusername\eclipse\jdk1.8.0_20\jre\bin\javaw.exe 因为它指定了eclipse应该在哪里找到要运行的JRE。这不管用。有人知道为什么吗?我在Window

Eclipse 如何定制m2e wtp部署?

在我的项目中,我有一些aar依赖项。我不想将这些aar文件部署到WEB-INF/lib文件夹中。我想在其他文件夹中部署它们。但是我找不到在哪里设置m2e wtp插件来实现这一点 我的pom文件如下所示: <dependency> <groupId>my.group</groupId> <artifactId>my-soap</artifactId> <type>aar</type> <ver

从Eclipse源代码编辑器中的圆圈-X复制错误消息文本

我正在尝试使用Eclipse修复Java Web应用程序中数百个XML验证错误。用谷歌搜索它们是非常痛苦的,因为到目前为止,这一直是我的工作流程: 在浏览器中打开谷歌 在Eclipse编辑器选项卡中单击错误所在的位置(显示为一个图标,在一行的开头是一个带白色“X”的红色圆圈),鼠标悬停,并尝试记住其中的一块 单击浏览器中的搜索表单,并尝试从内存复制块 重复步骤2-3,直到搜索表单中的文本与Eclipse在屏幕上短暂显示的文本匹配。通常,类似于: “cvc复杂类型.2.4.d:发现以元素'desc

Eclipse 为什么VS2015 intellisense在C+上显示错误+;11用户定义的文字(UDL)

下面的代码可以编译和运行,但VS2015 intellisense显示错误。g++&eclipse也有同样的问题(编译并运行,但显示错误) 有人知道怎么修吗?我试着在谷歌上搜索,但没有希望。 这个错误有点烦人…-) #包括 #包括 #包括 使用名称空间std; 使用名称空间std::literals; 使用名称空间chrono_文本; int main() { 此线程::睡眠时间(5s); cout您应该添加一些#包括语句和名称空间引用: #include <iostream>

Eclipse 如何使用Sonarint管理此场景?分支变化的微分分析

我们正在使用大量分支编写软件。使用EclipseSonar插件,我们在重新整合到基础分支之前分析了我们的分支。这里我们分析了遗留基本分支的新问题。只有在该处没有新问题时,才能开始重新融入社会 当切换到声纳时,我们不能再做这种类型的分析了。我们希望能够检查与基础分支相比的新问题。有没有可能用声纳来做这件事 谢谢你的帮助 克里斯蒂安这还不可能 该计划旨在支持跟踪未来版本中已解决的问题:

Eclipse maven tomcat插件-tomcat未运行

我是maven新手,我想使用maven tomcat插件运行我的web应用程序,我已经创建了maven项目,并在pom.xml中为tomcat添加了依赖项。我尝试运行构建项目,每次它在tomcat启动过程中停止 My pom.xml: <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="

Eclipse OSX非常不稳定

我是macOS的新用户 我是一名使用EclipseIDE很长一段时间都没有问题的开发人员。我最近在macOS Sierra购买了一台MacBook Pro Eclipse Neon.2在这种环境中一直不稳定 我的Eclipse在启动后挂起,所以我读到应该删除: /Workspace/.metadata/.plugins/org.eclipse.core.resources/.projects/jbosswildfly/.indexes 我启动了Eclipse,它正在工作。然后我重新启动了机器,

查看eclipse中执行的命令

我正在开发一个基于eclipse的产品。基本上,它是一个构建在eclipse之上的插件,它添加了多种功能、按钮、菜单项、新界面和其他东西。我想自动化一些日常任务,但我不知道幕后运行的是什么命令。是否有运行命令或类似内容的日志我没有访问源代码的权限,也无法联系产品所有者。没有简单的命令日志 您可以为Eclipse的许多不同组件启用跟踪,但是跟踪输出通常假定您对Eclipse内部结构了解很多 Eclipse的最新版本有一个首选项页,可以在“常规>跟踪”中启用跟踪。Eclipse帮助中描述了这一点 您

Eclipse 卡夫卡2.10源代码不可用

我在pom.xml中有以下依赖项。 为了调试,我需要检查一些类的源代码 <dependency> <groupId>org.apache.kafka</groupId> <artifactId>kafka_2.10</artifactId> <version>0.8.1.1</version> </dependency> org.apache.kafka 卡

Eclipse CXF-方法名称包含目标命名空间前缀

我有一个客户端应用程序来使用SOAP WS。该项目使用maven、Spring和CXF 3.1.12作为WS-consuming部分 我在Eclipse和IntelliJ社区中都有相同的项目。我在这两种情况下都执行mvn clean package,文件会自动生成以支持WS-consuming。类是使用wsdl2java生成的,WSDL文件包含在本地 当我在eclipse中执行一个测试用例时,我将发送以下SOAP XML消息(该消息工作正常) /我的档案/ 真的 真的 当我在Intelli

Eclipse maven在ubuntu中不使用环境变量工作

我目前正在一台ubuntu pc上工作。我在eclipse中创建了maven项目,并通过“干净安装”实现了目标。它创建了war文件 但是当我使用命令printenv 它在输出列表中没有显示与M2_HOME类似的内容 当我发出命令echo$M2_HOME时,它显示空白行 当我给出命令mvn--version时,它会给出流畅的输出 Apache Maven 3.3.9 Maven home: /usr/share/maven Java version: 1.8.0_151, vendor: Ora

将aspell作为用户定义字典添加到Eclipse

与Eclipse捆绑的默认英语词典有点弱,缺少许多单词,这些单词随后被错误地标记为错误。因此,我想更改为用户词典;这似乎可以在对话框窗口首选项常规文本编辑器拼写中实现 我已经尝试提供aspell文件夹中找到的.gz和.rws文件的路径,但Eclipse不接受任何路径。Eclipse在此对话框中需要哪个文件?需要的拼写词典格式是一个纯文本文件,每行一个单词。 我将指向首选项页面,在该页面的文本字段下方显示: 如果我听起来很生气,那我就是。不是发问者,而是删除了@greg-449原始答案的人,他们

为什么Eclipse中AWS工具包中的Elastic Beanstalk节点不显示我的环境?

我正在为Java开发人员使用最新的Eclipse IDE,版本:2019-03(4.11.0),构建id:20190314-1200,带有Java 12.0.1和AWS Toolkit v2 我将在第一个主题“更改环境配置设置”中遵循此文档 它告诉我双击AWS资源管理器中的Elastic Beanstalk节点以查看Elastic Beanstalk中的环境。然而,当我这样做时,我看不到我的任何环境在Elastic Beanstalk中运行 在Eclipse中我需要去哪里检查问题?如何修复此

  1    2   3   4   5   6  ... 下一页 最后一页 共 293 页